November 25, 2014 admin

Upgrading a Joomla! 1.5 site to a 2.5 site

What is an upgrade?

Upgrading your site ensures that you’re always running the most current version of Joomla out there.

Clients will periodically ask if they should upgrade their Joomla 1.0, or 1.5 site to a 2.5 site, or if we can do the upgrade for them. The amount of time and energy involved in an upgrade like this can vary greatly from one site to another. This article contains some things you will want to consider when determining how to proceed with an upgrade.

What should I consider before performing an upgrade?

The amount of time involved in the upgrade depends greatly on the amount 3rd party extensions that have been installed in the site and their compatibility with the 1.7 version. A core Joomla website that does not have any extensions installed can be upgraded easily, however this upgrade can be made more difficult if the site has an extension that is only compatible with the legacy (older) version of Joomla. It’s extremely important to remember that a template is an extension. If you upgrade, be sure that your template is compatible with the newer version of Joomla.

For instance, your site may have two image rotator extensions installed. The first being “Daily Banner”, a rotator that is only compatible with Joomla 1.5, and the second extension being “3D PowerSpin” which is available for both 1.5 and 2.5.

In order to upgrade from Joomla 1.5 to 2.5 in this case, we would need to find an alternate extension for the first extension mentioned above because it will no longer work after the upgrade. In fact, trying to install an extension that was intended for the 1.5 version into a 1.7 or 2.5 site can potentially cause serious problems if left in the site during an upgrade. If an upgrade is completely necessary, we will need you to perform the following:

1. Make a list of the extensions that you absolutely need in the site.
2. Research whether the extensions that you need are compatible with the new version of Joomla.
3. Find replacement extensions for the ones that are not compatible with the new version of Joomla.

The bottom line is, in order to upgrade your website from Joomla 1.5 to 2.5 without loosing functionality, you must first find replacements for the extensions that are not compatible with the new version of Joomla. The same is also true for upgrading to Joomla! 2.5.

Tagged: ,

Leave a Reply

Your email address will not be published. Required fields are marked *